Welcome to the Netflix Partner Help Center. Have a question or need help with an issue? Send us a ticket and we'll help you to a resolution.

Use the following examples to help you understand typical router configurations.

Arista EOS example configuration

!
router BGP <ASN>
neighbor <IP address of Appliance> remote-as 40027
neighbor <IP address of Appliance> route-map NETFLIX-OUT out
!
route-map NETFLIX-OUT permit 10
match ip address prefix-list NETFLIX-LOCAL
set metric 0
!
route-map NETFLIX-OUT permit 20
match ip address prefix-list NETFLIX-BACKUP
set metric 100
!
route-map NETFLIX-OUT deny 30
!

Brocade LAG BGP example configuration


lag "NETFLIX" dynamic
ports ethernet 1/7 to 1/8
primary-port 1/7
deploy
port-name "NETFLIX-OCA" ethernet 1/7
port-name "NETFLIX-OCA" ethernet 1/8
interface ethernet 1/7
enable
ip address <interface address/mask>
no ip redirect
ipv6 address <interface address/mask>
sflow forwarding
link-aggregate active
interface ethernet 1/8
enable
link-aggregate active

router bgp
neighbor Netflix peer-group
neighbor Netflix remote-as 40027
neighbor NetflixIPv6 peer-group
neighbor NetflixIPv6 remote-as 40027
neighbor <IPv4 address of Appliance> peer-group Netflix
neighbor <IPv4 address of Appliance> description "Netflix Open Cache Appliance"
neighbor <IPv6 address of Appliance> peer-group NetflixIPv6
neighbor <IPv6 address of Appliance> description "Netflix Open Cache Appliance"

address-family ipv4 unicast
neighbor Netflix prefix-list no-advertise in
neighbor Netflix prefix-list NETFLIX-LOCAL out
no neighbor NetflixIPv6 activate
exit-address-family

address-family ipv6 unicast
neighbor NetflixIPv6 activate
neighbor NetflixIPv6 prefix-list no-advertise-ipv6 in
neighbor NetflixIPv6 prefix-list NETFLIX-LOCAL-IPV6 out
exit-address-family

Cisco IOS BGP example configuration

!
router BGP <ASN>
neighbor <IP address of Appliance> remote-as 40027
neighbor <IP address of Appliance> route-map NETFLIX-OUT out
!
route-map NETFLIX-OUT permit 10
match ip address prefix-list NETFLIX-LOCAL
set metric 0
!
route-map NETFLIX-OUT permit 20
match ip address prefix-list NETFLIX-BACKUP
set metric 100
!
route-map NETFLIX-OUT deny 30
!

Cisco IOS XR BGP example configuration

!
router bgp <ASN>
neighbor <IP address of Appliance>
remote-as 40027
address-family ipv4 unicast
route-policy NETFLIX-OUT out
!
route-policy NETFLIX-OUT
if destination in NETFLIX-LOCAL then
set med 0
elseif destination in NETFLIX-BACKUP then
set med 100
else
drop
endif
end-policy
!
prefix-set NETFLIX-LOCAL
192.0.2.0/25,
192.168.100.0/25
end-set
!
prefix-set NETFLIX-BACKUP
192.0.2.128/25,
192.168.100.128/25
end-set
!

Cisco IOS XR LACP example configuration

!
interface Bundle-Ether1
bundle minimum-active bandwidth 1
ipv4 address <address/mask>
ipv6 address <really-long-address/mask>
!
interface TenGigE0/0/2/0
bundle id 1 mode active
lacp period short
!
interface TenGigE0/0/2/2
bundle id 1 mode active
lacp period short
!

Cisco IOS Interface LACP example configuration

!
interface Port-channel1
ip address <address> <mask>
!
interface GigabitEthernet1/1
channel-group 1 mode active
channel-protocol lacp
!
interface GigabitEthernet1/2
channel-group 1 mode active
channel-protocol lacp
!

Cisco IOS XR Bridged Interface example configuration

For multiple servers with LAG, using the same default gateway.

interface BVI100
description NETFLIX
ipv4 address <address/mask>
ipv6 address <really-long-address/mask>

l2vpn
load-balancing flow src-dst-ip
bridge group NETFLIX-OCAS
bridge-domain NETFLIX-OCAS
interface Bundle-Ether1
interface Bundle-Ether2
routed interface BVI100

interface Bundle-Ether1
l2transport
interface Bundle-Ether2
l2transport

Cisco IOS Switch with VLAN example configuration

For multiple servers in LAG groups, behind a switch.

! SVI Configuration
!
interface Vlan30
description **NETFLIX OCA SERVERS**
ip address <address/mask>

! Port channel configuration
!
interface Port-channel31
description **LINK TO NETFLIX-OCA-1**
switchport
switchport mode access
switchport access vlan 30
!
interface Port-channel32
description **LINK TO NETFLIX-OCA-2**
switchport
switchport mode access
switchport access vlan 30

! Interfaces configuration
!
! OCA1
interface TenGigabitEthernet1/1/1
description **LINK TO NETFLIX-OCA1-TEN0**
switchport
switchport mode access
switchport access vlan 30
channel-group 31 mode active
!
interface TenGigabitEthernet1/1/2
description **LINK TO NETFLIX-OCA1-TEN1**
switchport
switchport mode access
switchport access vlan 30
channel-group 31 mode active

! OCA2
interface TenGigabitEthernet2/1/1
description **LINK TO NETFLIX-OCA2-TEN0**
switchport
switchport mode access
switchport access vlan 30
channel-group 32 mode active
!
interface TenGigabitEthernet2/1/2
description **LINK TO NETFLIX-OCA2-TEN1**
switchport
switchport mode access
switchport access vlan 30
channel-group 32 mode active

Junos BGP example configuration


protocols {
    bgp {
        group NETFLIX {
            neighbor <IP address of Appliance> {
                export NETFLIX-EXPORT;
                peer-as 40027;
            }
        }
    }
}

policy-options {
    policy-statement NETFLIX-EXPORT {
        term NETFLIX-LOCAL {
            from {
                prefix-list NETFLIX-LOCAL;
            }
            then {
                metric 0;
                accept;
            }
        }
        term NETFLIX-BACKUP {
            from {
                prefix-list NETFLIX-BACKUP;
            }
            then {
                metric 100;
                accept;
            }
        }
        then reject;
    }
}

Junos Interface LACP example configuration

interfaces {
    ae1 {
        description NETFLIX-OCA;
        aggregated-ether-options {
            lacp {
                active;
                periodic fast;
            }
        }
        unit 0 {
            family inet {
                address <address/mask>;
            }
            family inet6 {
                address <really-long-address/mask>;
            }
        }
    }
    xe-0/0/0 {
        description NETFLIX-OCA-cxgbe0;
        ether-options {
            802.3ad ae1;
        }
    }
    xe-0/0/1 {
        description NETFLIX-OCA-cxgbe1;
        ether-options {
            802.3ad ae1;
        }
    }
}

Junos Bridged Interface example configuration

For multiple servers with LAG, using the same default gateway

vlans {
    NETFLIX-OCAS {
        vlan-id 100;
        l3-interface irb.100;
    }
}
interfaces {
    irb {
        unit 100 {
            family inet {
                address <address/mask>;
            }
            family inet6 {
                address <really-long-address/mask>;
            }
        }
    }
    ae0 {
        description NETFLIX-OCA-1;
        unit 0 {
            family ethernet-switching {
                vlan {
                    members NETFLIX-OCAS;
                }
            }
        }
    }
    ae1 {
        description NETFLIX-OCA-2;
        unit 0 {
            family ethernet-switching {
                vlan {
                    members NETFLIX-OCAS;
                }
            }
        }
    }
    xe-0/0/0 {
        description NETFLIX-OCA-1-PORT1;
        ether-options {
            802.3ad ae0;
        }
    }
    xe-0/0/1 {
        description NETFLIX-OCA-1-PORT2;
        ether-options {
            802.3ad ae0;
        }
    }
    xe-0/0/2 {
        description NETFLIX-OCA-2-PORT1;
        ether-options {
            802.3ad ae1;
        }
    }
    xe-0/0/3 {
        description NETFLIX-OCA-2-PORT2;
        ether-options {
            802.3ad ae1;
        }
    }
}
Was this article helpful?
0 out of 0 found this helpful